Data from notifications


New member

I recently set up Macrodroid on a new phone and transferred macros from the old one. I am having trouble with a macro I've used for a long time to log notifications received to a .csv file. It seemed to have worked fine, producing an output as expected like:

2021-07-17,22:38:59,"Scanner Radio","","","Alert for Worcester County, Massachusetts","","intentionally blank",""
2021-07-17,22:40:22,"Motorola Software Update","Background system installation","","","","intentionally blank",""

("intentionally blank" is some sort of joke to myself as I originally set up the wrong number of fields in the database this gets sent to and lazily added this instead of fixing it properly)

The phone (Moto G8) did a lot of updates, I don't know if that is the reason or something else, but since this point on 17 July the file produced instead contains the text macros entered with the ... button instead of the actual data, like this:

2021-07-17,23:01:40,"[not_app_name]","[not_title]","[not_ticker]","[notification]","[not_text_lines]","intentionally blank","[not_action_names]"

I've tried making new macros using these, fiddled with spaces around the " and , characters, etc, but no change.

Is there perhaps a settings or permissions issue I haven't yet found, or a bug or something else I overlooked that is causing this?

Many thanks.


New member
I found the reason and I have it working again. On my old phone for some reason I had to add a 5-second wait before writing to the file. On the new phone this causes the behaviour above. Removing the wait solved the problem.