New user. Paste action isn't working.

Dan567

New member
EDIT: I read on Google that clipboard access is restricted on Android 11. I just retested the Button Mapper app and the Paste action works in that app. Is there some permission I need to allow through ADB for MacroDroid?

I have defined an action to do a Paste from clipboard when long pressing the volume down button.
It doesn't work.

I know the trigger is working because I added an action to send a notification and that worked.
I also tried changing it from a Paste action to a Copy action and that didn't work either.
I changed the trigger to a floating button and that didn't help either.
I even changed it from a Paste from clipboard to just Paste the word Dog and that didn't help either.

I tried switching from Nova Launcher to One UI Home and that didn't help either.
I have turned off Button Mapper and Universal Copy. I don't know what other apps could be affecting this.
I have two other macros that I have created and they are working.
I used to have this macro defined in Button Mapper and it worked over there.

I entered the Paste action as follows:
Actions > Device Actions > UI Interaction > Paste > Clipboard Text

I am running on a Samsung Galaxy Tab S7+ running Android 11. I am using Nova Launcher.
I searched for this in this forum and in Google and couldn't find anything.

Any suggestions would be greatly appreciated.

Thanks
Dan
 
Last edited:

MacroDroidDev

Administrator
Staff member
You cannot read the contents of the clipboard in Android 11 I'm afraid. The paste action should still work if you store the text in a variable and use the contents of the variable to paste.
 

FrameXX

Active member
You can't paste content of clipboard with MacroDroid when MacroDroid is not in foreground. It does not have acces to clipboard than.
 
Top